spider blog

    Blog    

    Calendar    

SPIDER's blog

Since Monday 03 October 2005 04:30 pm

Public blogs:

This Week's Tweaks

Friday 26 March 2010 04:54 pm

menu navigation
still undergoing testing and changes on DEV server

PDP
fixed a few issues with ePDP layout, mainly so that new menu style works properly (issues with z-index)

inc_discussion_unread
fixed bug with query timing-out for users who had not ever 'marked read' dicussions. Changed to use distinct select so query returns far smaller result set

radiation stock
minor updates to allow for delivery of an offsite stock from GU

myAssignments
starting to update code to allow generic receipt delivery - currently hard coded for law school only

backups
have now set up cifs/samba on the backup server so that backup now takes place over a network share to the SIPBS disk storage array in the Royal College. No more back-up external drives and visits to the server room :)

quiz tools
quiz questions and quizzes can now be shared between users. Edit list bug fixed.

questionnaire tool
question and section ordering now available as AJAX drag and drop (same as for quizzes)

booking tool
now has collapsable headings for organising booking objects

widget-bar (DEV server)
variable width now allows user to specify number of columns columns. Added uni reg warning regarding adding inappropriate widgets. Supports google and widgetbox widget code.

workshop job tool
final updates now ready for end user final testing

 

 

  >  comment

This Week's Tweaks

Friday 19 March 2010 04:46 pm

uPortal
spent some time creating 'widgets' of some of SPIDERs bit n pieces to see how they would integrate with uPortal. Got news and classes to show up in the test uPortal system. Early observations are that it works well, but the uPortal admin interface is flakey - adding a 'web proxy' widget (which is the kind of widget that SPIDER lends itself to) seemed to be a bit hit and miss - you could add the widget config, and it wouldnt allow a uPortal user to add it. If you logged in and out again, it would suddenly start working. Whether this is down to uPortal itself or if its just the test config on the test server needs some work, not sure. Got it working in the end though, it just was a bit more work than it should be.

questionnaires
tweaked export results tool - SQL for admins showing qnnres in drop down was buggy.

class content category zip
class category pages now show a 'download all' option to students on the class list. This allows the download of all files in one categroy at once e.g. you can download all the "lecture slides" files at once.

classes - headings
added option to allow users to organise their myClasses under headings. On DEV server just now as it needs the menus navigation tool to be updated (see below) before I can put it on live.

BM310 lab reports
bug fix - commas in the user submitted text messing up display of saved content.

ePDP
strengths/ weaknesses extension - updated to force user to select title when adding/editing an entry - prior to this  users were able to store an entry with no title, which was causing it to be hidden from the user and their counsellor.

menu navigation
started to update the old javascript version of the menu navigation to a pure CSS version. Currently have basic system working, though IE 7 is causing problems with its non-standard way of handling some of the styles. Using some if IE conditional statements allows for work-around.  Still need to sort out some of the z-index issues in IE causing drop down menus to appear behind other sections of page (home page in particular).

widgets interface
bug fixes to allow 'widgets lite' on DEV server home page to work with Safari. Can now resize widget column.

workshop jobs tool
tool for tracking/ adding jobs for SIPBS workshop under final testing- potential for use by other staff roles?

 

 

 

  >  comment

This Week's Tweaks

Friday 12 March 2010 04:20 pm

PDP updates
modified the PDP manager (admin tool) and staff view of ePDP. PDP can now be credit bearing, have 0 credits or have 'P' for progress. Credits work as before (counsellor can assign or give no credit to the ePDP) but the P option allows for staff to indicate 'satisfactory progress'. In essence it works the same way, except there is no credit value assigned to the ePDP.  Also udpated the staff PDP progress view to indicate files updated per session as previously it could not do this (files were session independant).

research admin
minor tweaks to the finance data import tool

PG DB
updated report builder and report submission tool to allow for a 'notify' option - system will email the person listed in a notify field whenever a report is submitted.

questionnaires
updated class questionnaires so that staff cannot respond to them

polls
bug fix that was stopping class polls recording the class code correctly

widgets n gadgets
SPIDER-DEV now has a mostly working gadget/widget bar on the home page using the 'buttons' (default) navigation option

 

  >  comment

CentOS 5.4

Friday 05 March 2010 04:10 pm

updated back-up server 'bruce' to CentOS 5.4. Install went pretty smoothly, only issue was getting Dell OMSA (system monitoring s/w) working. The current version of OMSA is 6.2, but although this installed without any issues, it refused to recognise the PE2600 hardware, so shows up next to no useful information. Removed 6.2 and tried to get yum to install the OMSA 5.5 repo, but it insisted on always going back to the 6.2 repo. In the end, removed 6.2 and installed the 5.5 RHEL5 rpms by hand as per instructions on this site.  Some minor tweaks required to actually get it up and running, but its now happily working. It moaned a bit about the PERC 4Di firmware being out of date, so downloaded and upgraded that to keep it happy. Rebooted and all seems well. However, the whole point of this upgrade was to check if there was a h/w problem with the PCI bus - not according to OMSA there isnt, but CentOS 5.4 is refusing to see the external firewire backup drive... going to swap to the 2nd back up drive to see if it will be recognised.

  >  comment

1 comment

replying to myself... the 2nd drive was recognised ok, and since Friday all seems to be ok with the backup server - no orange flashing light, backup drive attached and working without issue. Net result - Fedora Core 9 or some part of it didn't like the PE2600 hardware. Going to stick with CentOS from now on.

Posted by Ian Tuesday 09 March 2010 10:35 am
You need to log onto Spider to add entries
You need to log in to Spider to post

<<March 2010>>
SMTWTFS
  1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31      

Archive

April 2016 [1]
November 2015 [1]
January 2015 [1]
July 2014 [1]
June 2014 [3]
May 2014 [4]
April 2014 [2]
March 2014 [3]
February 2014 [3]
January 2014 [2]
December 2013 [2]
November 2013 [2]
October 2013 [3]
September 2013 [2]
August 2013 [6]
July 2013 [3]
June 2013 [2]
May 2013 [4]
April 2013 [2]
March 2013 [3]
February 2013 [3]
January 2013 [2]
December 2012 [2]
November 2012 [4]
October 2012 [3]
September 2012 [4]
August 2012 [3]
July 2012 [2]
June 2012 [4]
May 2012 [2]
April 2012 [1]
March 2012 [4]
February 2012 [5]
January 2012 [3]
December 2011 [2]
November 2011 [3]
August 2011 [3]
July 2011 [5]
June 2011 [5]
May 2011 [5]
April 2011 [6]
March 2011 [6]
February 2011 [5]
January 2011 [4]
December 2010 [5]
November 2010 [11]
October 2010 [6]
September 2010 [6]
August 2010 [4]
July 2010 [7]
June 2010 [5]
May 2010 [5]
April 2010 [10]
March 2010 [4]
February 2010 [7]
January 2010 [5]
December 2009 [4]
November 2009 [12]
October 2009 [8]
September 2009 [2]
August 2009 [1]
July 2009 [3]
June 2009 [5]
May 2009 [2]
April 2009 [3]
March 2009 [5]
February 2009 [5]
January 2009 [2]
November 2008 [1]
August 2008 [1]
July 2008 [1]
June 2008 [1]
May 2008 [5]
April 2008 [5]
February 2008 [2]
November 2007 [2]
September 2007 [1]
August 2007 [3]
May 2007 [5]
March 2007 [2]
February 2007 [1]
November 2006 [2]
July 2006 [1]
May 2006 [1]
April 2006 [1]
March 2006 [4]
February 2006 [3]
January 2006 [3]
November 2005 [1]
October 2005 [4]

Favourite blogs